S50B32 problems with cam sync and more

All about our superior engine management unit.
Post Reply
teitur
Posts: 5
Joined: Sun Apr 22, 2018 5:20 pm

S50B32 problems with cam sync and more

Post by teitur » Sun Apr 22, 2018 11:12 pm

Hi

Have problems with secondary trigger signal on S50B32 engine.
All three trigger sensors are VR type. 60-2 cranck wheel, 6+1 exhaust and 6 intake wheel.
Can someone please check trigger settings, vanos settings and maps.
Attachments
sec trig set falling.emuscp
(465 Bytes) Downloaded 18 times
22.04.emu
(78.14 KiB) Downloaded 26 times
111.JPG

teitur
Posts: 5
Joined: Sun Apr 22, 2018 5:20 pm

Re: S50B32 problems with cam sync and more

Post by teitur » Sun Apr 22, 2018 11:22 pm

Added log 1732. At 1:02 engine stalled with backfire.

Also rough on idle and misfiring at lower rpm. Sometimes idles fine and stable until adding throttle.
Added second log where idle is fine 2:20 - 3:33. After touching pedal
Attachments
idle.emulog
(215.02 KiB) Downloaded 19 times
20180422_1732.emulog
(259.05 KiB) Downloaded 17 times

teitur
Posts: 5
Joined: Sun Apr 22, 2018 5:20 pm

Re: S50B32 problems with cam sync and more

Post by teitur » Mon Apr 23, 2018 4:33 pm

Scope logs. One with rising and other with falling edge secondary trigger.
Which one is correct?
Attachments
sec trig set rising.emuscp
(462 Bytes) Downloaded 24 times
sec trig set falling.emuscp
(465 Bytes) Downloaded 20 times

Karel
Posts: 408
Joined: Wed Sep 10, 2014 11:58 am
Location: Czech Republic
Contact:

Re: S50B32 problems with cam sync and more

Post by Karel » Mon Apr 23, 2018 9:32 pm

well, it looks like everytime ... shitty old wirring, and noisy mag signal from cams...... try to use some pulldown resistors ...... or make proper wirring harness and it will worl fine.

Karel
Posts: 408
Joined: Wed Sep 10, 2014 11:58 am
Location: Czech Republic
Contact:

Re: S50B32 problems with cam sync and more

Post by Karel » Mon Apr 23, 2018 9:45 pm

this is correct Scope
Attachments
scope_2017517_915.emuscp
(241 Bytes) Downloaded 22 times

teitur
Posts: 5
Joined: Sun Apr 22, 2018 5:20 pm

Re: S50B32 problems with cam sync and more

Post by teitur » Mon Apr 23, 2018 10:14 pm

Tried new shielded cable(separated from other wires) on sec trigger with no improvements.
Also changed over cam1 and cam2 sensors, tried another sensor from working car- same results.

Yes cam2 is noisy but thats not main problem at moment.
Small fluctuation may be from wiring but totally messed signal?

Will try resistors tomorrow.
Give me example what wire you recommend for vr sensors?

Karel
Posts: 408
Joined: Wed Sep 10, 2014 11:58 am
Location: Czech Republic
Contact:

Re: S50B32 problems with cam sync and more

Post by Karel » Mon Apr 23, 2018 11:45 pm

cca 1k Ohm will be my start something between 500 Ohm and 2k Ohm worked in most cases by me.

teitur
Posts: 5
Joined: Sun Apr 22, 2018 5:20 pm

Re: S50B32 problems with cam sync and more

Post by teitur » Wed Aug 29, 2018 10:33 am

Now signals are clean but its another problem. Camsync is working it shows cam signal but its not showing exhaust cam angle. Wiring is okey, sensor is okey(it will show signal normally) then we tryed another ecu --- still same story. We tryed even older version software but still same. It will not just showing exaust cam angle. Vanos is fysically okey and moving normaly. Have anybody ideas what can be wrong?

Post Reply
stół kuchenny okrągły

Who is online

Users browsing this forum: No registered users and 1 guest